Mikrotik01

Mikrotik RouterOs Series #1 – Escenario y configuración básica

Mikrotik RouterOs Series #1 – Escenario y configuración básica

 

Vamos a empezar una serie de artículos que van a tratar sobre el sistema operativo creado por la empresa letona Mikrotik, RouterOS, sistema que funciona sobre el hardware Routerboard diseñado por la misma marca.

 

El sistema operativo del router Mikrotik, basado en el kernel de Linux, nos permite utilizarlo como router, firewall, switch, VPN, establecer enlaces inalámbricos, …

 

Vamos a intentar, poco a poco, ir viendo todos, o la mayoría de aspectos para los que lo podemos utilizar.

 

Lo interesante sería poder contar con un dispositivo Routerboard, con el que poder hacer todas las pruebas que queramos, sobre todo para el apartado Wireless. Como puede que no sea el caso para todos los que estemos leyendo esto, y como siempre es mejor realizar pruebas en un entorno controlado antes que en producción, vamos a aprovechar para ver distintas formas de utilizar el sistema de Mikrotik, primero con Virtualbox (tanto las imángenes .iso, como las CHR), y más tarde usando GNS3.

 

Vamos a completar el escenario con un sistema operativo de escritorio virtualizado. En mi caso, voy a utilizar un Windows 7.

 

La idea final sería, en Virtualbox tener una MV con el sistema RouterOS, con dos interfaces de red, una será nuestra WAN (adaptador puente con nuestro host), otra la LAN para comunicar con nuestra MV de escritorio (adaptador red interna). Nos quedaría así.

Configurar Mikrotic Router Series #1 - Configuración Mikrotic

Lo primero que vamos a hacer es crear una MV de RouterOS que utilizaremos como plantilla, ya que en el futuro realizaremos pruebas que necsiten de más de un sistema RouterOS, y además, tenemos una licencia gratuita de 24 horas de uso, más que suficiente para nuestros laboratorios.

 

Primero descargamos la imagen de Mikrotik, tenemos varias ramas, utilizaremos la rama current y descargaremos la ISO:

configuracion mikrotik

Tras esto generamos una nueva máquina virtual. Le vamos a asignar 256MB de RAM, vamos a crear un disco duro virtual nuevo, con 512MB (tamaño dinámico, VDI):

mikrotik configurar

Tras esto, modificamos la MV. Vamos a quitar el disco del controlador SATA, y lo vamos a añadir al controlador IDE. Además, en la unidad de disco ponemos la ISO que hemos descargado anteriormente.

Ahora iniciamos la máquina y veremos los paquetes que podemos instalar. Seleccionamos los que vemos en la imagen con la barra espaciadora, y tras esto instalamos pulsando ‘i’:

Al terminar tendremos la MV instalada. Se reiniciará, la apagamos, quitamos la ISO y nos vamos en Virtualbox a Archivo, Administrador de medios virtuales, seleccionamos la imagen VDI, pulsamos en copiar y la copiamos a otra ubicación. Este archivo VDI será nuestra imagen origen para generar otras MV con RouterOS.

 

Ahora ya tenemos una MV con RouterOs instalado. Vamos a asignarle dos interfaces de red. La primera la habilitamos como Adaptador Puente con la interfaz de nuestro host, la segunda la habilitamos como Red Interna, le podemos dar de nombre LAN.

En nuestra MV de escritorio ponemos habilitamos el adaptador como Red Interna y seleccionamos en el desplegable la red que acabamos de generar, LAN.

 

Iniciamos ambas MV y ya tenemos todo dispuesto para empezar. Es recomendable haber descargado previamente Winbox, que es el software que nos va a permitir conectar a la gestión de Mikrotik con una interfaz gráfica.

 

Si todo ha ido bien, al iniciar Winbox e ir al menú de Neighbors, encontraremos la MV que hemos creado, con IP 0.0.0.0 y la MAC que haya generado. Vamos a hacer click sobre la MAC para conectar mediante esta, con usuario admin y contraseña en blanco.

Tras conectar nos sale la advertencia de ausencia de licencia y nos indica el tiempo que tenemos disponible para utilizar el router. Aceptamos.

Hecho esto vamos a conseguir que, primero nuestra MV con Mikrotik tenga Internet, y luego que nuestro sistema operativo virtualizado, en mi caso Windows 7, pueda acceder también a Internet a través de la MV Mikrotik.

 

Para ello, en Winbox, en el menú de la Izquierda tenemos la gran mayoría de aspectos que se pueden configurar, primero nos vamos a Interfaces. Veremos que tenemos dos, ether1 y ether2, en nuestro caso ether1 es nuestra WAN y ether2 es nuestra LAN. Mi recomendación es comentar siempre todo para que quede más claro.

Además, en las últimas versiones tenemos disponible la creación de Interface List, que no es más que un alias donde agrupamos distintas interfaces de red que cumplen una misma función de cara a su uso en reglas de Firewall (lo que se conoce como zonas en otras soluciones). En nuestro caso, de momento, no se nos da el caso, no obstante, vamos a generar nuestra lista WAN con ether1 y nuestra lista LAN con ether2, de cara a que en el futuro añadamos alguna interfaz adicional.

Ahora lo que vamos a hacer es que nuestra Mikrotik Virtual sea capaz de acceder a Internet. Para ello lo único que tenemos que hacer es añadir un cliente dhcp en la interfaz WAN, en nuestro caso que tenemos un servidor DHCP accesible desde la interfaz WAN (como podría ser el router ADSL de nuestro ISP). Vamos a dejar las opciones por defecto, obtendrá IP, ruta por defecto, DNS y NTP.

Al hacerlo vemos en el menú DHCP Client que obtenemos una dirección IP:

Además, en IP → Adresses vemos que se nos ha generado una entrada dinámica (D) con la IP obtenida:

En IP → Routes, tenemos la entrada de la ruta por defecto, y la entrada del rango de la IP obtenida.

Con esto ya salimos a Internet, si vamos a Tools → Ping, podemos hacer la prueba:

Lo único que queda es que nuestra MV con sistema operativo de escritorio tenga acceso a Internet. En IP → Adresses, añadimos una nueva IP, por ejemplo la siguiente, en la interfaz ether2, que es nuestra LAN. Esta IP será la puerta de enlace y DNS de la MV.

Ahora que tenemos IP, si nos configuramos una IP del rango 192.168.77.0/24, tendremos comunicación entre la Mikrotik y la MV a nivel de ping. Lo único que falta es enmascarar el tráfico de ese rango para que además el PC sea capaz de salir a Internet.

 

Nos vamos a IP → Firewall → NAT y generamos una regla srcnat (nat del origen), donde pondremos el rango origen (LAN), la interface list por la que sale el tráfico (WAN) y la acción (masquerade).

Con esto tenemos la configuración básica. Para poder trasladar esta configuración a cualquier otro dispositivo, teniendo en cuenta que además estamos trabajando con licencias de 24 horas, lo ideal es poder exportar la configuración actual para poderla importarla.

 

Nos vamos al menú de la izquierda y pulsamos sobre New Terminal. Tras pulsar se nos abre una ventana de terminal, como la de cualquier linux, en la que podemos escribir todos los comandos ( y más) que podemos realizar gráficamente, nosotros para exportar toda la configuración escribiremos lo siguiente:

Y al hacerlo, en el menú Files, nos encontraremos con el archivo generado por la exportación:

Ese archivo, lo podemos copiar y pegarlo en el escritorio de nuestro PC. Si lo abriésemos con un bloc de notas encontraríamos lo siguiente:

# dec/21/2016 08:38:11 by RouterOS 6.37.3

# software id = XYXY-ZZB3

#

/interface ethernet

set [ find default-name=ether1 ] comment=WAN

set [ find default-name=ether2 ] comment=LAN

/ip neighbor discovery

set ether1 comment=WAN

set ether2 comment=LAN

/interface list

add name=WAN

add name=LAN

/interface list member

add interface=ether1 list=WAN

add interface=ether2 list=LAN

/ip address

add address=192.168.77.254/24 interface=ether2 network=192.168.77.0

/ip dhcp-client

add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \

interface=ether1

/ip firewall nat

add action=masquerade chain=srcnat out-interface-list=WAN src-address=\

192.168.77.0/24

 

Y todo esto no es más que la configuración que hemos aplicado.

 

Hemos ido poco a poco, mucha gente ya conocerá el sistema, pero en las próximas entregas iremos entrando a fondo en cosas más interesantes.

 

Hasta la próxima.